Back to overview
Degraded
Feeds page and short page disruption
Jul 25 at 02:00pm CEST
Affected services
CRM
Resolved
Jul 25 at 10:26pm CEST
Issue is now solved
Affected services
Created
Jul 25 at 02:00pm CEST
A Zoho update has dropped the elements concerning notification feeds. Due to this outage, we invite you to follow your mail notifications until the affected pages return.
Affected services